MDT 2012 Boot Image creation error in SCCM 2012

So – MDT 2012 is out and, as I explored in a previous post, it integrates nicely with SCCM 2012 RC.

If you jump into the administration console and try to make an MDT-based boot image, you will probably encounter this error:

“Could not find a part of the path ‘C:ToolsPEToolsx86WinPE_FPs'” or “Could not find a part of the path ‘C:ToolsPEToolsx64WinPE_FPs'”

Could not find a part of the path 'C:ToolsPEToolsx86WinPE_FPs'

Looks like there’s an MDT 2012 bug in the form of a hard-coded link to reference the presence of the Windows Automated Installation Kit (WAIK) –  all the necessary files are to be found in “C:Program FilesWindows AIKToolsPEToolsx86WinPE_FPs” (or x64, depending on the architecture of the boot image you’re creating).

Simply copying the ..Tools.. folder and all the subfolders to C: will get around this error.  It’s clunky, but given that the problematic bit of code probably lies within one of the MDT DLLs (my money is on Microsoft.BDD.Wizards.dll) then there’s not much we can do right now, unless you’re really, really keen on uncompiling/recompiling DLLs.

UPDATE 30/11/2011 – After some discussion with the most awesome Michael Niehaus, there’s definitely not a hard link to C:.  The ConfigMgr Console needs to be run as Administrator, and then it all works fine. Not sure whether this is functionality which will make it all the way through to the RTM, so we’ll see.

UPDATE 09/12/2011 – Yet more awesomeness from Michael Niehaus. This is a reproducible issue in the current beta and will be resolved in the Release Candidate of MDT 2012.

 

8 comments to MDT 2012 Boot Image creation error in SCCM 2012

Leave a Reply to Aaron Whittaker Cancel reply

You can use these HTML tags

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>